// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/(?:www\.)?youtube\.com\b").unwrap();
let string = "https://www.youtube.com/watch?v=AAAAAAAAAAA
https://www.youtube.comm/watch?v=AAAAAAAAAA
https://youtube.com/watch?v=AAAAAAAAAAA
https://youtube.comm/watch?v=AAAAAAAAAAA
youtube.com/watch?v=AAAAAAAAAAA
www.youtube.com/watch?v=AAAAAAAAAAA
https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}