const regex = /^https:\/\/(?:www\.)?youtube\.com\b/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(?:www\\.)?youtube\\.com\\b', 'mg')
const str = `https://www.youtube.com/watch?v=AAAAAAAAAAA
https://www.youtube.comm/watch?v=AAAAAAAAAA
https://youtube.com/watch?v=AAAAAAAAAAA
https://youtube.comm/watch?v=AAAAAAAAAAA
youtube.com/watch?v=AAAAAAAAAAA
www.youtube.com/watch?v=AAAAAAAAAAA
https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}