using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/(?:www\.)?youtube\.com\b";
string input = @"https://www.youtube.com/watch?v=AAAAAAAAAAA
https://www.youtube.comm/watch?v=AAAAAAAAAA
https://youtube.com/watch?v=AAAAAAAAAAA
https://youtube.comm/watch?v=AAAAAAAAAAA
youtube.com/watch?v=AAAAAAAAAAA
www.youtube.com/watch?v=AAAAAAAAAAA
https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}