const regex = /^[1][0][0]\.[0]{2}\%|[1-9]?[0-9]\.[0-9]{2}\%$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1][0][0]\\.[0]{2}\\%|[1-9]?[0-9]\\.[0-9]{2}\\%$', 'gm')
const str = `Valid:
100.00%
2.00%
22.00%
2.99%
invalid:
02.00%
110.00%
200.00%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}