import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1][0][0]\\.[0]{2}\\%|[1-9]?[0-9]\\.[0-9]{2}\\%$";
final String string = "Valid:\n"
+ "100.00%\n"
+ "2.00%\n"
+ "22.00%\n"
+ "2.99%\n\n\n"
+ "invalid:\n"
+ "02.00%\n"
+ "110.00%\n"
+ "200.00%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}