using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1][0][0]\.[0]{2}\%|[1-9]?[0-9]\.[0-9]{2}\%$";
string input = @"Valid:
100.00%
2.00%
22.00%
2.99%
invalid:
02.00%
110.00%
200.00%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}