import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"https:\\/\\/www\\.occhialifabbricatorino\\.it\\/images(.*).jpg\"";
final String string = "@extends('frontend.layout')\n\n"
+ "@section('head_styles')\n"
+ " <!-- @owlcarousel -->\n"
+ " <link rel=\"stylesheet\"\n"
+ " href=\"{{ asset('/owl.carousel/dist/assets/owl.carousel.min.css') }}\" />\n\n"
+ " <link rel=\"stylesheet\"\n"
+ " href=\"{{ asset('/owl.carousel/dist/assets/owl.theme.default.min.css') }}\" />\n"
+ " <style>\n"
+ " .owl-carousel.owl-theme {\n"
+ " display: block !important;\n"
+ " }\n\n"
+ " #home_vetrina__carousel .home_vetrina__item {\n"
+ " height: 16rem;\n"
+ " }\n"
+ " </style>\n"
+ " <!-- @owlcarousel -->\n"
+ "@endsection\n\n"
+ "@section('mainsection')\n"
+ " <section class=\"mainsection\">\n"
+ " <!-- home fascia banner -->\n"
+ " <div class=\"row home-row-banner\">\n"
+ " <div id=\"carouselSlideBanner\"\n"
+ " class=\"col carousel slide\"\n"
+ " data-ride=\"carousel\">\n"
+ " <div class=\"row carousel-inner\">\n"
+ " <div style=\"background-image: url({{ asset('frontend/home/home-banner-01.jpg') }})\"\n"
+ " class=\"carousel-item carousel-item-banner-1 winter2021 active\"></div>\n"
+ " <div style=\"background-image: url({{ asset('frontend/home/home-banner-02.jpg') }})\"\n"
+ " class=\"carousel-item carousel-item-banner-2 winter2021\"></div>\n"
+ " <div style=\"background-image: url({{ asset('frontend/home/home-banner-03.jpg') }})\"\n"
+ " class=\"carousel-item carousel-item-banner-3 winter2021\"></div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"row home-row-slogan mb-3 mb-lg-5 mt-3 mt-lg-5\">\n"
+ " <div class=\"col\">\n"
+ " <h1>Occhiali di alta qualità, realizzati a mano in Italia <span class=\"fe_underlined\">con rispetto</span>.\n"
+ " </h1>\n"
+ " <!--TODO:translate-->\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"row home_row_catalogue d-lg-none mb-5\">\n"
+ " <div class=\"col-6 col-woman\">\n"
+ " <div class=\"row woman-links\">\n"
+ " <div class=\"col-12 d-flex align-items-center justify-content-center \">\n"
+ " <a class=\"nav-link\"\n"
+ " href=\"/vista/?gender=F\">Vista</a>\n"
+ " </div>\n"
+ " <div class=\"col-12 d-flex justify-content-center col_hr\">\n"
+ " <hr>\n"
+ " </div>\n"
+ " <div class=\"col-12 d-flex align-items-center justify-content-center \">\n"
+ " <a class=\"nav-link\"\n"
+ " href=\"/sole/?gender=F\">Sole</a>\n"
+ " </div>\n"
+ " </div>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/catalogue_woman.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " <p class=\"fe_catalogue_label\">Donna</p>\n"
+ " </div>\n"
+ " <div class=\"col-6 col-man\">\n"
+ " <div class=\"row man-links\">\n"
+ " <div class=\"col-12 d-flex align-items-center justify-content-center pl-0 \">\n"
+ " <a class=\"nav-link\"\n"
+ " href=\"/vista/?gender=M\">Vista</a>\n"
+ " </div>\n"
+ " <div class=\"col-12 d-flex justify-content-center pl-0 col_hr\">\n"
+ " <hr>\n"
+ " </div>\n"
+ " <div class=\"col-12 d-flex align-items-center justify-content-center pl-0 \">\n"
+ " <a class=\"nav-link\"\n"
+ " href=\"/sole/?gender=M\">Sole</a>\n"
+ " </div>\n"
+ " </div>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/catalogue_man.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " <p class=\"fe_catalogue_label\">Uomo</p>\n"
+ " </div>\n"
+ " </div>\n\n\n\n"
+ " <div class=\"row home_row_showroom d-flex justify-content-center mb-5\">\n"
+ " <div class=\"col d-flex justify-content-center\">\n"
+ " <div class=\"row justify-content-center d-none d-lg-block\">\n"
+ " <div class=\"col-12 col-md-8 col-lg-12 d-flex m-auto\">\n"
+ " <!--<img src=\"https://www.occhialifabbricatorino.it/images/showrooms_desktop_scritta.jpg\" class=\"img-fluid fe_scritta_showroom\">-->\n"
+ " <a href=\"/showroom/#showroom_torino\"\n"
+ " class=\"d-flex maxWidth maxHeight mr-3\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/showrooms_desktop_torino.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " <a href=\"/showroom/#showroom_roma\"\n"
+ " class=\"d-flex maxWidth maxHeight mr-3\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/showrooms_desktop_roma.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " <a href=\"/showroom/#showroom_milano\"\n"
+ " class=\"d-flex maxWidth maxHeight mr-3\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/showrooms_desktop_milano.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " </div>\n"
+ " </div>\n"
+ " <div class=\"row justify-content-center d-lg-none maxWidth\">\n"
+ " <div class=\"col-12 col-md-8 d-flex justify-conetnt-center flex-column p-0\"\n"
+ " style=\"position:relative\">\n"
+ " <!--<img src=\"https://www.occhialifabbricatorino.it/images/showrooms_desktop_scritta.jpg\" class=\"img-fluid fe_showroom_mobile_scritta\">-->\n"
+ " <a href=\"/showroom/#showroom_torino\"\n"
+ " class=\"\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/showrooms_mobile_torino.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " <a href=\"/showroom/#showroom_roma\"\n"
+ " class=\"mt-3\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/showrooms_mobile_roma.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " <a href=\"/showroom/#showroom_milano\"\n"
+ " class=\"mt-3\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/showrooms_mobile_milano.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"row home_row_shop mb-5 d-none d-lg-flex\">\n"
+ " <div id=\"home_vetrina\"\n"
+ " class=\"col-12 text-center\">\n"
+ " {{-- @owlcarousel --}}\n\n\n"
+ " <div id=\"home_vetrina__carousel\"\n"
+ " class=\"owl-carousel owl-theme\">\n"
+ " <?php $items = range(0, 12); ?>\n"
+ " @foreach ($items as $value)\n"
+ " <a class=\"home_vetrina__item\"\n"
+ " href=\"/sole/1473-s-montepulciano/\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/media/1473_montepulciano_a01s_front_bollinorec.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " @endforeach\n"
+ " </div>\n\n\n"
+ " </div>\n"
+ " </div>\n\n\n\n\n"
+ " <div class=\"row home_row_bio d-flex justify-content-center mb-5\">\n"
+ " <div class=\"col col-md-8 col-lg-10 d-flex justify-content-center\">\n"
+ " <button class=\"btn fe_btn2 d-none d-lg-block\"><a href=\"/sostenibilita/\">scopri</a></button>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/sustainability.jpg\"\n"
+ " class=\"img-fluid d-none d-lg-block\">\n"
+ " <a href=\"/sostenibilita/\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/bioacetate_mobile.jpg\"\n"
+ " class=\"img-fluid d-lg-none\">\n"
+ " </a>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"row home_row_showroom d-flex justify-content-center mb-5\">\n"
+ " <div class=\"col-12 col-lg text-center\">\n"
+ " <a href=\"/prova-a-casa/\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/tryhome.jpg\"\n"
+ " class=\"img-fluid d-none d-lg-block maxWidth\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/tryhome_mobile.jpg\"\n"
+ " class=\"img-fluid d-lg-none\">\n"
+ " </a>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"row home_row_ft d-flex justify-content-center mb-5\">\n"
+ " <div class=\"col-12 col-md-8 col-lg-12 d-flex flex-nowrap d-lg-none\">\n"
+ " <a href=\"/ft-lab/\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/ft_lab_mobile.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/ft_project_mobile.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " <a href=\"/ft-eco/\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/ft_eco_mobile.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </a>\n"
+ " </div>\n"
+ " <div class=\"col-5 justify-content-end d-none d-lg-flex\">\n"
+ " <div>\n"
+ " <button class=\"btn fe_btn2 fe_btn_eco\"><a href=\"/ft-eco/\">scopri</a></button>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/ft_eco.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " </div>\n"
+ " <div class=\"col-5 justify-content-start d-none d-lg-flex\">\n"
+ " <div>\n"
+ " <button class=\"btn fe_btn2 fe_btn_lab\"><a href=\"/ft-lab/\">scopri</a></button>\n"
+ " <!--translate-->\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/ft_lab.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"row home_row_likeyou mb-5\">\n"
+ " <div class=\"col-12 ml-3\">\n"
+ " <img src=\"/images/justylikeyou.png\"\n"
+ " class=\"img-fluid fe_justlikeyou\">\n"
+ " </div>\n"
+ " <div class=\"col-12 text-center\">\n"
+ " <div class=\"container-fluid fe_slideshow_container\">\n"
+ " <i class=\"material-icons arrow arrow_left\">chevron_left</i>\n"
+ " <i class=\"material-icons arrow arrow_right\">chevron_right</i>\n"
+ " <div class=\"row fe_slideshow mt-3 g-0\">\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto1.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto2.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto3.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto4.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto5.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto6.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto7.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto8.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " <div class=\"box\"\n"
+ " style=\"height: 306px;\">\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto9.jpg\"\n"
+ " class=\"img-fluid\">\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <!-- home fascia dicono di noi -->\n"
+ " <div class=\"row home-row-diconodinoi\">\n"
+ " <div id=\"carouselSlideDiconoDiNoi\"\n"
+ " class=\"col carousel slide\"\n"
+ " data-ride=\"carousel\">\n"
+ " <div class=\"row carousel-inner\">\n"
+ " <div class=\"carousel-item carousel-item-diconodinoi-1 active\"></div>\n"
+ " <div class=\"carousel-item carousel-item-diconodinoi-2\"></div>\n"
+ " <div class=\"carousel-item carousel-item-diconodinoi-3\"></div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <!-- home fascia 2 -->\n"
+ " <div class=\"home-row-2\">\n"
+ " <!-- col-12 -->\n"
+ " <div>\n"
+ " <!-- riga 1 -->\n"
+ " <div>\n"
+ " <div>\n"
+ " <h4>Come funziona?</h4>\n"
+ " </div>\n"
+ " </div>\n"
+ " <!-- riga 2 -->\n"
+ " <div>\n"
+ " <div>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/scegli.png\">\n"
+ " <h5>Prova a casa</h5>\n"
+ " <p>>Scegli fino a 3 occhiali da provare comodamente a casa tua gratuitamente. Hai fino a 3 giorni\n"
+ " di tempo per provarli senza fretta e farti consigliare.</p>\n"
+ " </div>\n"
+ " <div>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/spedisci.png\">\n"
+ " <h5>Ritiro dei campioni</h5>\n"
+ " <p>Scaduti i 3 giorni, ritireremo i campioni gratuitamente nel momento a te più comodo.</p>\n"
+ " </div>\n"
+ " <div>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/guarda.png\">\n"
+ " <h5>Inserisci la ricetta</h5>\n"
+ " <p>Inserisci la tua ricetta oculistica e seleziona i trattamenti delle lenti che desideri.</p>\n"
+ " </div>\n"
+ " <div>\n"
+ " <img src=\"https://www.occhialifabbricatorino.it/images/acquista.png\">\n"
+ " <h5>Completa l'acquisto</h5>\n"
+ " <p>Ricevi l'occhiale completo di lenti graduate presso l'ottico partner più vicino a te.</p>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div id=\"popupnewsletter\"\n"
+ " class=\"modal fade\">\n"
+ " <div class=\"fe_news_bg\"\n"
+ " onclick=\"closepopupnewsletter();\"></div>\n"
+ " <div class=\"popupcontainer\">\n"
+ " <span onclick=\"closepopupnewsletter();\"\n"
+ " class=\"closepopup\"\n"
+ " style=\"background-color:#0000006e\">X</span>\n"
+ " <form action=\"\"\n"
+ " method=\"post\"\n"
+ " onsubmit=\"return submittedpopupnewsletter(this);\"\n"
+ " class=\"fe_popnews_form\">\n"
+ " <div class=\"row\">\n"
+ " <div class=\"col-12 col-lg-6 fe_popnews_colsx\">\n"
+ " <h4>ISCRIVITI ALLA NEWSLETTER!</h4>\n"
+ " <p>Avrai il <strong>10% di sconto</strong></p>\n"
+ " <p>sul tuo <strong>primo acquisto</strong></p>\n"
+ " <hr class=\"fe_popupnews_hr\">\n"
+ " <p>Sarai sempre <strong>aggiornato/a</strong></p>\n"
+ " <p>su <strong>promozioni e novità</strong></p>\n\n"
+ " <input type=\"email\"\n"
+ " name=\"mail\"\n"
+ " value=\"\"\n"
+ " required=\"\"\n"
+ " placeholder=\"E-mail\">\n"
+ " <input type=\"submit\"\n"
+ " name=\"submit\"\n"
+ " value=\"OTTIENI LO SCONTO\">\n"
+ " </div>\n"
+ " <div class=\"col-12 col-lg-6 fe_popnews_coldx\">\n\n"
+ " </div>\n"
+ " </div>\n"
+ " <input type=\"hidden\"\n"
+ " name=\"action\"\n"
+ " value=\"registertonewsletter\">\n"
+ " </form>\n"
+ " </div>\n"
+ " </div>\n\n"
+ " </section>\n"
+ "@endsection\n"
+ "@section('body_script')\n"
+ " <!-- @owlcarousel -->\n"
+ " <script src=\"{{ asset('/owl.carousel/dist/owl.carousel.min.js') }}\"></script>\n"
+ " <script>\n"
+ " $(document).ready(function() {\n"
+ " $(\"#home_vetrina__carousel\").owlCarousel({\n"
+ " margin: 10,\n"
+ " loop: true,\n"
+ " // autoWidth: true,\n"
+ " items: 5,\n"
+ " // ,\n"
+ " // nav:true,\n"
+ " dots: false\n"
+ " });\n"
+ " });\n"
+ " </script>\n"
+ " <!-- @owlcarousel -->\n"
+ "@endsection\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}