using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""https:\/\/www\.occhialifabbricatorino\.it\/images(.*).jpg""";
string input = @"@extends('frontend.layout')
@section('head_styles')
<!-- @owlcarousel -->
<link rel=""stylesheet""
href=""{{ asset('/owl.carousel/dist/assets/owl.carousel.min.css') }}"" />
<link rel=""stylesheet""
href=""{{ asset('/owl.carousel/dist/assets/owl.theme.default.min.css') }}"" />
<style>
.owl-carousel.owl-theme {
display: block !important;
}
#home_vetrina__carousel .home_vetrina__item {
height: 16rem;
}
</style>
<!-- @owlcarousel -->
@endsection
@section('mainsection')
<section class=""mainsection"">
<!-- home fascia banner -->
<div class=""row home-row-banner"">
<div id=""carouselSlideBanner""
class=""col carousel slide""
data-ride=""carousel"">
<div class=""row carousel-inner"">
<div style=""background-image: url({{ asset('frontend/home/home-banner-01.jpg') }})""
class=""carousel-item carousel-item-banner-1 winter2021 active""></div>
<div style=""background-image: url({{ asset('frontend/home/home-banner-02.jpg') }})""
class=""carousel-item carousel-item-banner-2 winter2021""></div>
<div style=""background-image: url({{ asset('frontend/home/home-banner-03.jpg') }})""
class=""carousel-item carousel-item-banner-3 winter2021""></div>
</div>
</div>
</div>
<div class=""row home-row-slogan mb-3 mb-lg-5 mt-3 mt-lg-5"">
<div class=""col"">
<h1>Occhiali di alta qualità, realizzati a mano in Italia <span class=""fe_underlined"">con rispetto</span>.
</h1>
<!--TODO:translate-->
</div>
</div>
<div class=""row home_row_catalogue d-lg-none mb-5"">
<div class=""col-6 col-woman"">
<div class=""row woman-links"">
<div class=""col-12 d-flex align-items-center justify-content-center "">
<a class=""nav-link""
href=""/vista/?gender=F"">Vista</a>
</div>
<div class=""col-12 d-flex justify-content-center col_hr"">
<hr>
</div>
<div class=""col-12 d-flex align-items-center justify-content-center "">
<a class=""nav-link""
href=""/sole/?gender=F"">Sole</a>
</div>
</div>
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/catalogue_woman.jpg""
class=""img-fluid"">
<p class=""fe_catalogue_label"">Donna</p>
</div>
<div class=""col-6 col-man"">
<div class=""row man-links"">
<div class=""col-12 d-flex align-items-center justify-content-center pl-0 "">
<a class=""nav-link""
href=""/vista/?gender=M"">Vista</a>
</div>
<div class=""col-12 d-flex justify-content-center pl-0 col_hr"">
<hr>
</div>
<div class=""col-12 d-flex align-items-center justify-content-center pl-0 "">
<a class=""nav-link""
href=""/sole/?gender=M"">Sole</a>
</div>
</div>
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/catalogue_man.jpg""
class=""img-fluid"">
<p class=""fe_catalogue_label"">Uomo</p>
</div>
</div>
<div class=""row home_row_showroom d-flex justify-content-center mb-5"">
<div class=""col d-flex justify-content-center"">
<div class=""row justify-content-center d-none d-lg-block"">
<div class=""col-12 col-md-8 col-lg-12 d-flex m-auto"">
<!--<img src=""https://www.occhialifabbricatorino.it/images/showrooms_desktop_scritta.jpg"" class=""img-fluid fe_scritta_showroom"">-->
<a href=""/showroom/#showroom_torino""
class=""d-flex maxWidth maxHeight mr-3"">
<img src=""https://www.occhialifabbricatorino.it/images/showrooms_desktop_torino.jpg""
class=""img-fluid"">
</a>
<a href=""/showroom/#showroom_roma""
class=""d-flex maxWidth maxHeight mr-3"">
<img src=""https://www.occhialifabbricatorino.it/images/showrooms_desktop_roma.jpg""
class=""img-fluid"">
</a>
<a href=""/showroom/#showroom_milano""
class=""d-flex maxWidth maxHeight mr-3"">
<img src=""https://www.occhialifabbricatorino.it/images/showrooms_desktop_milano.jpg""
class=""img-fluid"">
</a>
</div>
</div>
<div class=""row justify-content-center d-lg-none maxWidth"">
<div class=""col-12 col-md-8 d-flex justify-conetnt-center flex-column p-0""
style=""position:relative"">
<!--<img src=""https://www.occhialifabbricatorino.it/images/showrooms_desktop_scritta.jpg"" class=""img-fluid fe_showroom_mobile_scritta"">-->
<a href=""/showroom/#showroom_torino""
class="">
<img src=""https://www.occhialifabbricatorino.it/images/showrooms_mobile_torino.jpg""
class=""img-fluid"">
</a>
<a href=""/showroom/#showroom_roma""
class=""mt-3"">
<img src=""https://www.occhialifabbricatorino.it/images/showrooms_mobile_roma.jpg""
class=""img-fluid"">
</a>
<a href=""/showroom/#showroom_milano""
class=""mt-3"">
<img src=""https://www.occhialifabbricatorino.it/images/showrooms_mobile_milano.jpg""
class=""img-fluid"">
</a>
</div>
</div>
</div>
</div>
<div class=""row home_row_shop mb-5 d-none d-lg-flex"">
<div id=""home_vetrina""
class=""col-12 text-center"">
{{-- @owlcarousel --}}
<div id=""home_vetrina__carousel""
class=""owl-carousel owl-theme"">
<?php $items = range(0, 12); ?>
@foreach ($items as $value)
<a class=""home_vetrina__item""
href=""/sole/1473-s-montepulciano/"">
<img src=""https://www.occhialifabbricatorino.it/media/1473_montepulciano_a01s_front_bollinorec.jpg""
class=""img-fluid"">
</a>
@endforeach
</div>
</div>
</div>
<div class=""row home_row_bio d-flex justify-content-center mb-5"">
<div class=""col col-md-8 col-lg-10 d-flex justify-content-center"">
<button class=""btn fe_btn2 d-none d-lg-block""><a href=""/sostenibilita/"">scopri</a></button>
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/sustainability.jpg""
class=""img-fluid d-none d-lg-block"">
<a href=""/sostenibilita/"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/bioacetate_mobile.jpg""
class=""img-fluid d-lg-none"">
</a>
</div>
</div>
<div class=""row home_row_showroom d-flex justify-content-center mb-5"">
<div class=""col-12 col-lg text-center"">
<a href=""/prova-a-casa/"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/tryhome.jpg""
class=""img-fluid d-none d-lg-block maxWidth"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/tryhome_mobile.jpg""
class=""img-fluid d-lg-none"">
</a>
</div>
</div>
<div class=""row home_row_ft d-flex justify-content-center mb-5"">
<div class=""col-12 col-md-8 col-lg-12 d-flex flex-nowrap d-lg-none"">
<a href=""/ft-lab/"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/ft_lab_mobile.jpg""
class=""img-fluid"">
</a>
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/ft_project_mobile.jpg""
class=""img-fluid"">
<a href=""/ft-eco/"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/ft_eco_mobile.jpg""
class=""img-fluid"">
</a>
</div>
<div class=""col-5 justify-content-end d-none d-lg-flex"">
<div>
<button class=""btn fe_btn2 fe_btn_eco""><a href=""/ft-eco/"">scopri</a></button>
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/ft_eco.jpg""
class=""img-fluid"">
</div>
</div>
<div class=""col-5 justify-content-start d-none d-lg-flex"">
<div>
<button class=""btn fe_btn2 fe_btn_lab""><a href=""/ft-lab/"">scopri</a></button>
<!--translate-->
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/ft_lab.jpg""
class=""img-fluid"">
</div>
</div>
</div>
<div class=""row home_row_likeyou mb-5"">
<div class=""col-12 ml-3"">
<img src=""/images/justylikeyou.png""
class=""img-fluid fe_justlikeyou"">
</div>
<div class=""col-12 text-center"">
<div class=""container-fluid fe_slideshow_container"">
<i class=""material-icons arrow arrow_left"">chevron_left</i>
<i class=""material-icons arrow arrow_right"">chevron_right</i>
<div class=""row fe_slideshow mt-3 g-0"">
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto1.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto2.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto3.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto4.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto5.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto6.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto7.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto8.jpg""
class=""img-fluid"">
</div>
<div class=""box""
style=""height: 306px;"">
<img src=""https://www.occhialifabbricatorino.it/images/banner/it/home/gallery2/foto9.jpg""
class=""img-fluid"">
</div>
</div>
</div>
</div>
</div>
<!-- home fascia dicono di noi -->
<div class=""row home-row-diconodinoi"">
<div id=""carouselSlideDiconoDiNoi""
class=""col carousel slide""
data-ride=""carousel"">
<div class=""row carousel-inner"">
<div class=""carousel-item carousel-item-diconodinoi-1 active""></div>
<div class=""carousel-item carousel-item-diconodinoi-2""></div>
<div class=""carousel-item carousel-item-diconodinoi-3""></div>
</div>
</div>
</div>
<!-- home fascia 2 -->
<div class=""home-row-2"">
<!-- col-12 -->
<div>
<!-- riga 1 -->
<div>
<div>
<h4>Come funziona?</h4>
</div>
</div>
<!-- riga 2 -->
<div>
<div>
<img src=""https://www.occhialifabbricatorino.it/images/scegli.png"">
<h5>Prova a casa</h5>
<p>>Scegli fino a 3 occhiali da provare comodamente a casa tua gratuitamente. Hai fino a 3 giorni
di tempo per provarli senza fretta e farti consigliare.</p>
</div>
<div>
<img src=""https://www.occhialifabbricatorino.it/images/spedisci.png"">
<h5>Ritiro dei campioni</h5>
<p>Scaduti i 3 giorni, ritireremo i campioni gratuitamente nel momento a te più comodo.</p>
</div>
<div>
<img src=""https://www.occhialifabbricatorino.it/images/guarda.png"">
<h5>Inserisci la ricetta</h5>
<p>Inserisci la tua ricetta oculistica e seleziona i trattamenti delle lenti che desideri.</p>
</div>
<div>
<img src=""https://www.occhialifabbricatorino.it/images/acquista.png"">
<h5>Completa l'acquisto</h5>
<p>Ricevi l'occhiale completo di lenti graduate presso l'ottico partner più vicino a te.</p>
</div>
</div>
</div>
</div>
<div id=""popupnewsletter""
class=""modal fade"">
<div class=""fe_news_bg""
onclick=""closepopupnewsletter();""></div>
<div class=""popupcontainer"">
<span onclick=""closepopupnewsletter();""
class=""closepopup""
style=""background-color:#0000006e"">X</span>
<form action=""
method=""post""
onsubmit=""return submittedpopupnewsletter(this);""
class=""fe_popnews_form"">
<div class=""row"">
<div class=""col-12 col-lg-6 fe_popnews_colsx"">
<h4>ISCRIVITI ALLA NEWSLETTER!</h4>
<p>Avrai il <strong>10% di sconto</strong></p>
<p>sul tuo <strong>primo acquisto</strong></p>
<hr class=""fe_popupnews_hr"">
<p>Sarai sempre <strong>aggiornato/a</strong></p>
<p>su <strong>promozioni e novità</strong></p>
<input type=""email""
name=""mail""
value=""
required=""
placeholder=""E-mail"">
<input type=""submit""
name=""submit""
value=""OTTIENI LO SCONTO"">
</div>
<div class=""col-12 col-lg-6 fe_popnews_coldx"">
</div>
</div>
<input type=""hidden""
name=""action""
value=""registertonewsletter"">
</form>
</div>
</div>
</section>
@endsection
@section('body_script')
<!-- @owlcarousel -->
<script src=""{{ asset('/owl.carousel/dist/owl.carousel.min.js') }}""></script>
<script>
$(document).ready(function() {
$(""#home_vetrina__carousel"").owlCarousel({
margin: 10,
loop: true,
// autoWidth: true,
items: 5,
// ,
// nav:true,
dots: false
});
});
</script>
<!-- @owlcarousel -->
@endsection
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}