# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([A-z0-9-_]+)(([^>\"]+\"[^\"]*\")*\s*)/>"
test_str = (" <div class=\"bbn-flex-fill\">\n"
" <div v-if=\"arrowsPosition.startsWith('top')\"\n"
" class=\"bbn-flex bbn-bottom-sspace\"\n"
" :style=\"arrowsStyle\">\n"
" <i v-show=\"showArrowLeft\"\n"
" :class=\"[leftArrowClass, 'bbn-p', 'bbn-lg']\"\n"
" @click=\"prev\"\n"
" :style=\"{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}\"/>\n"
" <i v-show=\"showArrowRight\"\n"
" @click=\"next\"\n"
" :class=\"[\n"
" rightArrowClass,\n"
" 'bbn-p',\n"
" 'bbn-lg'\n"
" ]\"\n"
" :style=\"{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}\"/>\n"
" </div>\n"
" </div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.