import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([A-z0-9-_]+)(([^>\"]+\"[^\"]*\")*\\s*)/>";
final String string = " <div class=\"bbn-flex-fill\">\n"
+ " <div v-if=\"arrowsPosition.startsWith('top')\"\n"
+ " class=\"bbn-flex bbn-bottom-sspace\"\n"
+ " :style=\"arrowsStyle\">\n"
+ " <i v-show=\"showArrowLeft\"\n"
+ " :class=\"[leftArrowClass, 'bbn-p', 'bbn-lg']\"\n"
+ " @click=\"prev\"\n"
+ " :style=\"{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}\"/>\n"
+ " <i v-show=\"showArrowRight\"\n"
+ " @click=\"next\"\n"
+ " :class=\"[\n"
+ " rightArrowClass,\n"
+ " 'bbn-p',\n"
+ " 'bbn-lg'\n"
+ " ]\"\n"
+ " :style=\"{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}\"/>\n"
+ " </div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}