const regex = new RegExp('<([A-z0-9-_]+)(([^>"]+"[^"]*")*\\s*)/>', 'gm')
const str = ` <div class="bbn-flex-fill">
<div v-if="arrowsPosition.startsWith('top')"
class="bbn-flex bbn-bottom-sspace"
:style="arrowsStyle">
<i v-show="showArrowLeft"
:class="[leftArrowClass, 'bbn-p', 'bbn-lg']"
@click="prev"
:style="{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}"/>
<i v-show="showArrowRight"
@click="next"
:class="[
rightArrowClass,
'bbn-p',
'bbn-lg'
]"
:style="{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}"/>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}