re = /<option[^>]*>([^<]*)<\/option>/m
str = '<option value="TY009">Assessment/Calculator</option>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end