$re = '/<option[^>]*>([^<]*)<\/option>/m';
$str = '<option value="TY009">Assessment/Calculator</option>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);