// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^#].*)?^\s*dev1").unwrap();
let string = "#| Environment | Port-prefix | Subnet | Target-host |
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
#dev1 300 8 ibdock2
# dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev1 300 8 ibdock2
dev 301 1 ibdock2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}