#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^#].*)?^\s*dev1"
Local $sString = "#| Environment | Port-prefix | Subnet | Target-host |" & @CRLF & _
"#dev1 300 8 ibdock2" & @CRLF & _
"# dev1 300 8 ibdock2" & @CRLF & _
" #dev1 300 8 ibdock2" & @CRLF & _
" # dev1 300 8 ibdock2" & @CRLF & _
"dev1 300 8 ibdock2" & @CRLF & _
" dev1 300 8 ibdock2" & @CRLF & _
"dev 301 1 ibdock2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")