import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^#].*)?^\\s*dev1";
final String string = "#| Environment | Port-prefix | Subnet | Target-host |\n"
+ "#dev1 300 8 ibdock2\n"
+ "# dev1 300 8 ibdock2\n"
+ " #dev1 300 8 ibdock2\n"
+ " # dev1 300 8 ibdock2\n"
+ "dev1 300 8 ibdock2\n"
+ " dev1 300 8 ibdock2\n"
+ "dev 301 1 ibdock2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}