$re = '/^([1-5]|6[0-5])|66.0($|(\.[0-5]))/m';
$str = '66.0.1
66.0.3
66.0.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);