package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-5]|6[0-5])|66.0($|(\.[0-5]))`)
var str = `66.0.1
66.0.3
66.0.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}