const regex = /^([1-5]|6[0-5])|66.0($|(\.[0-5]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-5]|6[0-5])|66.0($|(\\.[0-5]))', 'gm')
const str = `66.0.1
66.0.3
66.0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}