import Foundation
let pattern = #"(https:\/\/(t|tlgrm|telegram)\.me\/|tg:\/\/)proxy\?server=.+&port=[0-9]{0,5}&secret=[a-z0-9]{32}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"tg://proxy?server=198.143.181.185&port=80&secret=b378518a9d340be274076e73c994d4cb"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)