$re = '/(https:\/\/(t|tlgrm|telegram)\.me\/|tg:\/\/)proxy\?server=.+&port=[0-9]{0,5}&secret=[a-z0-9]{32}/';
$str = 'tg://proxy?server=198.143.181.185&port=80&secret=b378518a9d340be274076e73c994d4cb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);