re = /(https:\/\/(t|tlgrm|telegram)\.me\/|tg:\/\/)proxy\?server=.+&port=[0-9]{0,5}&secret=[a-z0-9]{32}/
str = 'tg://proxy?server=198.143.181.185&port=80&secret=b378518a9d340be274076e73c994d4cb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end