$re = '/<p>(?:\s| )*?<\/p>/i';
$str = '<p></p>
<p> </p>
<p> </p>
<p>foo</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);