package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<p>(?:\s| )*?<\/p>`)
var str = `<p></p>
<p> </p>
<p> </p>
<p>foo</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}