$re = '/[bcf]at/i';
$str = 'rat bat cat sat fat cats eat tat cat mat CAT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);