package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[bcf]at`)
var str = `rat bat cat sat fat cats eat tat cat mat CAT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}