use strict;
my $str = 'Ik gebruik altijd een zin als w8woord';
my $regex = qr/^(?#at least one capital letter)(?=.*?[A-Z])(?#at leaste one lower case letter)(?=(.*[a-z]))(?#at leaste one number)(?=(.*[\d]))(?#at leaste one non letter or number)(?=(.*[^a-zA-Z0-9])).{6,}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}