#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?#at least one capital letter)(?=.*?[A-Z])(?#at leaste one lower case letter)(?=(.*[a-z]))(?#at leaste one number)(?=(.*[\d]))(?#at leaste one non letter or number)(?=(.*[^a-zA-Z0-9])).{6,}$"
Local $sString = "Ik gebruik altijd een zin als w8woord"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")