# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(restaur*|bar|brasserie|\sbouches?\s) "
test_str = ("[activités idéales]\n"
"activités idéales : opticien lunetier, restauration rapide\n\n"
"[IDEALMENT DEDIE]\n"
"idéalement destiné à une activités de restauration\n"
"idéalement à une belle enseigne de pizzeria franchisée\n"
"idéalement pensé pour une activité de restauration\n"
"idéalement être transformée en restaurant\n"
"idéalement dédiée à la restauration\n\n"
"[IDEAL POUR]\n"
"idéal pour un restaurant\n"
"idéal pour des commerces de proximité et/ou de bouches\n"
"déal pour toutes activités de restauration\n"
"idéal pour la restauration\n"
"idéal pour de la restauration avec ou sans nuisances\n"
"idéal pour un bar\n\n"
"[usage de ..]\n"
"usage de brasserie\n"
"usage de restauration\n\n"
"[LOCAL A USAGE DE..]\n"
"local à usage de supérette alimentaire\n"
"local à usage de restauration\n\n"
"[AUTRES]\n"
"restaurant de plus de x couverts?\n"
"restaurant de x couverts\n"
"pour de la restauration\n"
"ideal petite restauration\n"
"usage de restauration\n"
"possibilité : restaurant\n"
"possibilité de restauration\n"
"restauration éventuelle\n"
"dédié à la restauration\n"
"à destination de restauration\n"
"activités comme restaurant\n"
"activités comme restauration\n"
"un bâtiment restauration\n"
"restauration autorisé\n"
"restauration sans nuisance\n"
"restauration froide ou sans nuisance\n"
"restauration rapide ou alimentaire\n"
"restaurant avec conduit de cheminée\n"
"la restauration est possible\n"
"restaurant avec une très belle visibilité\n"
"restaurant en angle\n"
"ce restaurant \n"
"ce joli restaurant\n"
"commerce de restauration\n"
"(un|ce) restaurant dispose\n"
"propose (un|ce) restaurant\n"
"restaurant avec licence\n"
"(une|cette) restauration rapide/snack\n"
"(un|ce) restaurant rapide \n"
"y compris restauration\n"
"un restaurant avec hotte à charbon\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.