package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(restaur*|bar|brasserie|\sbouches?\s) `)
var str = `[activités idéales]
activités idéales : opticien lunetier, restauration rapide
[IDEALMENT DEDIE]
idéalement destiné à une activités de restauration
idéalement à une belle enseigne de pizzeria franchisée
idéalement pensé pour une activité de restauration
idéalement être transformée en restaurant
idéalement dédiée à la restauration
[IDEAL POUR]
idéal pour un restaurant
idéal pour des commerces de proximité et/ou de bouches
déal pour toutes activités de restauration
idéal pour la restauration
idéal pour de la restauration avec ou sans nuisances
idéal pour un bar
[usage de ..]
usage de brasserie
usage de restauration
[LOCAL A USAGE DE..]
local à usage de supérette alimentaire
local à usage de restauration
[AUTRES]
restaurant de plus de x couverts?
restaurant de x couverts
pour de la restauration
ideal petite restauration
usage de restauration
possibilité : restaurant
possibilité de restauration
restauration éventuelle
dédié à la restauration
à destination de restauration
activités comme restaurant
activités comme restauration
un bâtiment restauration
restauration autorisé
restauration sans nuisance
restauration froide ou sans nuisance
restauration rapide ou alimentaire
restaurant avec conduit de cheminée
la restauration est possible
restaurant avec une très belle visibilité
restaurant en angle
ce restaurant
ce joli restaurant
commerce de restauration
(un|ce) restaurant dispose
propose (un|ce) restaurant
restaurant avec licence
(une|cette) restauration rapide/snack
(un|ce) restaurant rapide
y compris restauration
un restaurant avec hotte à charbon
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}