$re = '/\b[2-7a-z]{16}\.onion\b/';
$str = '2345672345672345.onion.to';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);