package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[2-7a-z]{16}\.onion\b`)
var str = `2345672345672345.onion.to`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}