re = /(text|simple)(?![^<]*>|[^<>]*<\/)/m
str = 'This is simple html text <span class=\'simple\'>simple simple text text</span> text'
subst = '<span class=\'notranslate\'>$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result