import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(text|simple)(?![^<]*>|[^<>]*<\\/)";
final String string = "This is simple html text <span class='simple'>simple simple text text</span> text";
final String subst = "<span class='notranslate'>$1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}