re = /^[\p{L}\p{M}]+([\p{L}\p{Pd}\p{Zs}'.]*[\p{L}\p{M}])+$|^[\p{L}\p{M}]+$/m
str = 'Mr. स्वागत स्वागत'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end