package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{L}\p{M}]+([\p{L}\p{Pd}\p{Zs}'.]*[\p{L}\p{M}])+$|^[\p{L}\p{M}]+$`)
var str = `Mr. स्वागत स्वागत`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}