re = /^(pinkglass|greenapple)\s(redbook|bluepen|yellowglass)\s(pinkglass|greenapple)$/m
str = 'pinkglass redbook greenapple
greenapple bluepen pinkglass'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end