package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(pinkglass|greenapple)\s(redbook|bluepen|yellowglass)\s(pinkglass|greenapple)$`)
var str = `pinkglass redbook greenapple
greenapple bluepen pinkglass`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}