re = /.*\(([[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*,){5}[[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*\)/
str = 'lc_checkout(int job, feature, version, nlic, flag, key )'
# Print the match result
str.match(re) do |match|
puts match.to_s
end