package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\(([[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*,){5}[[:blank:]]*[[:alnum:]]*[[:blank:]]*\**[[:blank:]]*[[:alnum:]]*[[:blank:]]*\)`)
var str = `lc_checkout(int job, feature, version, nlic, flag, key )`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}