$re = '/[^a-zA-Z0-1000]/';
$str = 'user_id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);