package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z0-1000]`)
var str = `user_id`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}