// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}.+\d{2}:\d{2})\s(?<level>[^:]+):\s(?<body>.*)$").unwrap();
let string = "2024-04-27T03:03:27+00:00 DEBUG (7): Hello world!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}