$re = '/^(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}.+\d{2}:\d{2})\s(?<level>[^:]+):\s(?<body>.*)$/m';
$str = '2024-04-27T03:03:27+00:00 DEBUG (7): Hello world!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);