const regex = /([M]\d{1,4}T?|[AB]\d{1,4}M?)-[0-9]{1,4}[A|B|J|K|L|M]\d?/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([M]\\d{1,4}T?|[AB]\\d{1,4}M?)-[0-9]{1,4}[A|B|J|K|L|M]\\d?', 'm')
const str = `
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}