package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([M]\d{1,4}T?|[AB]\d{1,4}M?)-[0-9]{1,4}[A|B|J|K|L|M]\d?`)
var str = `
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}