$re = '/(?\'entity\'\b(?!group\b)\w+)(?\'filter\'\(\w*:["\w*\/\-) ]*)? ?{/m';
$str = '{
group(fullPath: "volit") {
labels {
nodes {
title
id
}
}
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);