#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?'entity'\b(?!group\b)\w+)(?'filter'\(\w*:["\w*\/\-) ]*)? ?{"
Local $sString = "{" & @CRLF & _
" group(fullPath: "volit") {" & @CRLF & _
" labels {" & @CRLF & _
" nodes {" & @CRLF & _
" title" & @CRLF & _
" id" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")