use strict;
my $str = '/_d/assets/bifocal/themes/read/planeta/main.js
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/_d/openbook.json
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/portada.htm?cmpt=eyJzcGluZSI6MH0=--e2876ee89281460bea1897f7a52c8031aeefe2d1
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/images/logo_b.jpg
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/';
my $regex = qr/^(https?:\/\/)?([\w\-\.]*)?((?:[\w-]*\/)*)(\w+\.\w+)?(\?.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}