const regex = /^(https?:\/\/)?([\w\-\.]*)?((?:[\w-]*\/)*)(\w+\.\w+)?(\?.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)?([\\w\\-\\.]*)?((?:[\\w-]*\\\/)*)(\\w+\\.\\w+)?(\\?.*)?$', 'gm')
const str = `/_d/assets/bifocal/themes/read/planeta/main.js
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/_d/openbook.json
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/portada.htm?cmpt=eyJzcGluZSI6MH0=--e2876ee89281460bea1897f7a52c8031aeefe2d1
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/images/logo_b.jpg
https://933d-36654f7d51ea15b57af7205017bc9ea5.aquafadas-readiverse.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}